Linux x64 SMP client - WoW

Joined
Jan 15, 2002
Messages
3,173
Location
Salem, Or
#1
If people want to have some fun: Try the beta SMP x64 Linux client.

I just tried running it on one of my x2 4600+. To complicate matters, the machine is running Windows x64 (you can use a regular 32 bit Windows at a slight frame time cost) and I'm running Ubuntu x64 linux from inside a free VMware server. It took some fiddling to make it work, mainly because I know little to nothing about Linux. You should be able to gain even more efficiency by skipping Windows and VMware by running Linux directly.

On that machine I got a p3027 WU worth 771 points. It's been running for 34.5 minutes and has completed 10% which calculates out to aprox 3,200PPD. WoW. I'll just have to wait to see if that rate continues, but if so, it takes point whoring to a brand new level because that one x2 4600+ machine is almost out producing everything I've got combined (three x1900 GPU's + five x2 4600's and three 3.2GHz P4's).
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
12,785
Location
USA
#2
Very nice! I'll have to get my vmware workstation setup and running and give it a try. That sounds like a nice improvement over what we have now!
 
Joined
Jan 15, 2002
Messages
3,173
Location
Salem, Or
#3
After giving it some time, I've found that the Linux system clock, inside VMware, runs much slower than the Windows clock, on my machine. It's messing with my frame times and PPD calculations. From my current calculations, the Linux clock is running aprox 1/4 the rate of true time and that means 3200PPD is closer to 800PPD. Still good, but not what it was. I just knew 3200PPD was too good to be true.
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
12,785
Location
USA
#4
Yes, the clocks get wonky in vmware because they poll at a 1000Hz in the 2.6 Kernel vs 10Hz in the 2.4 kernel. I've had many problems with clock polling in ESX server with the 2.6 kernel. It also causes higher CPU usage because it tries to keep up with the polling. I don't think there is a great solution for this other than to try recompiling and setting it back to 10Hz...which I sadly do not know how to do.
 
Top