Androids Browser

LunarMist

I can't believe I'm a Fixture
Joined
Feb 1, 2003
Messages
15,380
Location
USA
My phone is having problems with the internet. I get errors on some sites and others display warnings.
I think may be caused by the Android, version 2.3.6. The phone company will not update it.
Are there any decent 3rd party bowsers I can install on a phone of that vintage? Thanks.
 

Mercutio

Fatwah on Western Digital
Joined
Jan 17, 2002
Messages
20,507
Location
I am omnipresent
Website
s-laker.org
Firefox does still run on Android 2.3. In my experience, it's pretty crashy on anything less than 512MB RAM, so that's of limited value for low-spec devices.
 
Top