Antivirus breaks email

time

Storage? I am Storage!
Joined
Jan 18, 2002
Messages
4,924
Location
Brisbane, Oz
This is a heads up in case anyone else encounters an issue like it.

User 1 and User 2 each have their own PC.
User 1 has four email accounts, A, B, C and D, where B, C and D are Gmail accounts.
User 2 has two email accounts, A and E, where E is a Gmail account.
User 1 connects to email account A from a Thunderbird account with POP3.
User 2 connects to email account A from two separate Thunderbird accounts, one with POP3 and one with IMAP.
Both users connect to all their Gmail accounts from Thunderbird with IMAP.
Yes, they share email account A.

Everything that follows had the benefit of hindsight.

Over a couple of days, mail stopped coming into the Thunderbird Gmail accounts.
Trying to send an email through Gmail raised an error that mentioned Sent Mail.
Email account A continued to work normally for both User 1 and User 2 when accessed with POP3, but the second Thunderbird account with IMAP behaved the same as the Gmail accounts, i.e. dead as a dodo.

Two of the Gmail accounts still worked on smartphones.
One of the Gmail accounts still worked on an iPad. This ruled out the router and the ISP.
Disabled the firewalls on the PCs, but to no avail.
Tried creating a new Thunderbird account, but no joy.
Testing showed that Thunderbird was sending emails OK but was unable to copy them to Sent Mail.

The problem looked like Thunderbird had broken IMAP, presumably through an auto-update. Both PCs were running current versions of Thunderbird. The obvious snag was the few million other users who presumably were still getting their email.

The true cause is probably obvious to you as you metaphorically sit back in your armchair, but in real time, with hysterical users on the opposite sides of a building yelling at each other over the phone, it was a shit show. :)

Web research turned up similar issues with Avast Antivirus, and then with Eset.
User 1 was running Eset Antivirus (NOD32) and User 2 was running Eset Internet/Smart Security, both current versions (7.3?).
So, I asked them both to try: Setup - Web and email - Email client protection - Email Protocols, then disable "Enable email protection by protocol filtering".
User 2 was fixed (Yay!), but there was no change to User 1.
Progressively moved up the hierarchy, disabling along the way, tried a restart, but still no change.
Tried disabling everything, including Host Protection or something similar that required a restart. Nothing.
Gave up and uninstalled Eset completely from User 1's PC. Everything fixed and back to normal.

I advised User 1 to rely on Windows Defender for a while, at least until Eset gets their act together.
Continuous Integration / Continuous Delivery strikes again!
HTH
 
Top