Firefox, SF Cookies

mubs

Storage? I am Storage!
Joined
Nov 22, 2002
Messages
4,908
Location
Somewhere in time.
#1
I seem to have this problem every time I use a new PC to access SF. But it's the worst this time, because I started with a fresh install of FF 16.0.2 instead of upgrading on top of very old versions.

I always have FF delete all cookies on exit. SF is the only site listed to be an exception. storageforum.net is allowed to store cookies (and they are), but I'm still asked to log in by SF.

What do I need to do to fix this?

Thanks.

Slightly off-topic, a fresh install of FF 16 has many irritants compared to installing 16 on top of older versions. I'm getting really pi**ed.
 

mubs

Storage? I am Storage!
Joined
Nov 22, 2002
Messages
4,908
Location
Somewhere in time.
#3
I've done that, not a problem. In W7, with the fresh install, the bookmarks button leaves the bookmarks open permanently till I close it. My office laptop running W7 woks like I want it to - floats the bookmarks and closes the bookmarks as soon as I choose one. But it ran several older versions of FF before being upgraded to 16. I suspect they support legacy configs, but don't allow these configs on fresh installs.

Another is the downloads window. It accumulates the list of downloads and doesn't clear the list till I do. And of course, the cookies thing.
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
12,887
Location
USA
#4
I'll have to try and recreate the problem. I'm assuming if you do not have FF clear out cookies on exit that things work fine? I know that's not what you want, but just as a confirmation that the default install works correctly. I admit I can't find the options where I can have a site remembered for cookies and to have others cleared on exit.
 

mubs

Storage? I am Storage!
Joined
Nov 22, 2002
Messages
4,908
Location
Somewhere in time.
#5
I'll try your suggestion. I'll also try clearing out SF cookies and having them re-stored.

Options > Privacy tab. The Exceptions button next to "Accept cookies from sites" has an Allow button that enables permanent cookies for sites you specify.

I don't think this is an SF problem; it's with FF.

Thanks.
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
12,887
Location
USA
#6
I'll try your suggestion. I'll also try clearing out SF cookies and having them re-stored.

Options > Privacy tab. The Exceptions button next to "Accept cookies from sites" has an Allow button that enables permanent cookies for sites you specify.

I don't think this is an SF problem; it's with FF.

Thanks.

Oh I see where I went wrong. I was looking in the privacy section but I didn't know I had to change the drop down box from "Remember history" to "use custom settings...". Now I see what you are referencing.
 

mubs

Storage? I am Storage!
Joined
Nov 22, 2002
Messages
4,908
Location
Somewhere in time.
#7
Fixed. Stupid FF wasn't behaving. It behaved inconsistently. Most recently, it was clearing SF cookies when it wasn't supposed to. I cycled through the whole range of options step by step, logging in to SF a million times. Finally got it to stick. There a bug or two there somewhere.
 
Top