Forum moved and upgraded

Handruin

Administrator
Joined
Jan 13, 2002
Messages
13,021
Location
USA
The YouTube videos should hopefully be fixed now. I found a search & replace plugin that allowed me to update about 100 posts with YouTube videos. If you find other ones that don't work please let me know and I'll fix them.
 

Newtun

Storage is nice
Joined
Nov 21, 2002
Messages
298
Location
Virginia
I noticed yesterday that some older "internal forum links" in threads are no longer functional, presumably because of the forum-conversion complexities. I also assume that this issue may be too difficult to remedy, and not worth the effort, so we may need to just accept it and move on.

An example is the post https://www.storageforum.net/forum/threads/something-random.3070/post-205841, in The Dude's "here" links.
 

LunarMist

I can't believe I'm a
Joined
Feb 1, 2003
Messages
15,250
Location
USA
The link works for me. Perhaps it was fixed in the last half hour.
 

LunarMist

I can't believe I'm a
Joined
Feb 1, 2003
Messages
15,250
Location
USA
I see. Meanwhile I just got that gateway error again.

504 Gateway Time-out
nginx/1.8.0
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
13,021
Location
USA
I greped through all my logs and I can't find any instance of a 504 Gateway timeout. I don't understand what steps you're taking to get that error.
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
13,021
Location
USA
The link above works, but if you go to the linked post, the "here" links in that do not.
I see the issue you're describing. Inside SD's post, he makes a link to another storageforum.net thread at this location:

http://www.storageforum.net/forum/showthread.php/11322-My-Experience-Ripping-a-Damaged-Bad-CD-amp-How-to-possibly-recover-it-(v-guide)

I may be able to search and replace it to something like:
http://www.storageforum.net/forum/threads/My-Experience-Ripping-a-Damaged-Bad-CD-amp-How-to-possibly-recover-it-(v-guide).11322

The two parts that changed are showthread.php becomes threads and the thread ID 11322 moves from the beginning to the end of the URL.
 

LunarMist

I can't believe I'm a
Joined
Feb 1, 2003
Messages
15,250
Location
USA
I made a small error in the title of a thread and cannot not figure out a method to fix the typo. Does the forum have that functionality?
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
13,021
Location
USA
Yeah but it expires after a certain amount of time. What would you like fixed?
 

snowhiker

Storage Freak Apprentice
Joined
Jul 5, 2007
Messages
1,511
Yeah but it expires after a certain amount of time. What would you like fixed?
Perhaps the edit timer can be extended for just Lunar and myself. Lunar's always making typos and f'ing up links and I'm OCD and anal about my posts.
 

LunarMist

I can't believe I'm a
Joined
Feb 1, 2003
Messages
15,250
Location
USA
How will waiting longer fix link problems? I assumed that this new, modern forum would not have as many link problems.
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
13,021
Location
USA
The proposal was to have the post editable longer so that when you make your mistakes with linking sites you can go fix it yourself. The old forum never had issues with linking sites nor does this one.
 

LunarMist

I can't believe I'm a
Joined
Feb 1, 2003
Messages
15,250
Location
USA
Well, I'll see how it goes in 2020 when I am forced to the Windows 10. Maybe there is some way to test the links and not lose the page, but that usually occurs. Of course a longer time will not harm anything.
 

LunarMist

I can't believe I'm a
Joined
Feb 1, 2003
Messages
15,250
Location
USA
What is happening to threads? David had a couple of Latest Posts listed today and then they disappeared. :unsure:
 

LunarMist

I can't believe I'm a
Joined
Feb 1, 2003
Messages
15,250
Location
USA
It looks different again, especially the circular user icons. The format is fine for my satellite, but some others are a bit truncated now.
Is the new software possibly better at impeding the Chinese?
 

Stereodude

Not really a
Joined
Jan 22, 2002
Messages
10,561
Location
Michigan
It looks different again, especially the circular user icons. The format is fine for my satellite, but some others are a bit truncated now.
Is the new software possibly better at impeding the Chinese?
What makes you think the Chinese aren't the ones who changed the forum? :ROFLMAO:
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
13,021
Location
USA
I did a software update last night to get us up to date. There are some slight changes as you've noticed. I've made some additional tweaks to the spam management, so time will tell if they help at all.
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
13,021
Location
USA
It's been almost one week and I don't recall there being any spam making it to the main forum. I think things have been a little better so far. The anti spam management has been flagging new registered accounts and stopping them from posting. I've been deleting them behind the scenes but that's typical even with the previous version. Now it's easier to manage those accounts which is nice.
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
13,021
Location
USA
Thanks Newtun! The behind the scenes work has been minimal these days which is good. Just software/OS patching for security stuff and maintaining backups.
 
Top