Firefox/Palemoon Android Issue

Mercutio

Fatwah on Western Digital
Joined
Jan 17, 2002
Messages
20,329
Location
I am omnipresent
Website
s-laker.org
#1
I've found that I can't submit a form on SF using recent builds of Firefox or Palemoon for Android. I'm just checking on my phone and a couple tablets. I'm definitely logged in. It's just like the "submit reply" button doesn't do anything. Can anyone else replicate that?
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
12,874
Location
USA
#2
I can reproduce it with Firefox on Android. I can't even log in because the submit button does nothing. If I switch to the full site layout the login button works. This may point a finger to the mobile style having an issue. I'll see if I can find updates or references to this issue.
 

Stereodude

Not really a
Joined
Jan 22, 2002
Messages
10,252
Location
Michigan
#6
I use the request desktop site option and it works fine. I generally don't like mobile sites, as least on my tablet. I don't really browse the internet with a phone.
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
12,874
Location
USA
#7
My apologies I slacked off and didn't look into this as I had offered. I'll take a look tonight and at least report back something on the matter even if it's still I don't know the solution.
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
12,874
Location
USA
#8
I suspect there is something strange with the support for older versions of jquery and the latest version of Android Firefox but I haven't conclusively determined this yet. I've tried updating/downgrading and changing the jquery packages for both core and mobile and even went so far as to update us to the latest vbulletin 4.2.3 but so far I still can't get the mobile theme to work under Firefox. One way I found around the issue as a hack is to use the Android keyboard enter arrow after filling in your username and password. One my device that submitted login but it's by no means a solution to the problem. I'll take a look into this further on Friday.
 

mubs

Storage? I am Storage!
Joined
Nov 22, 2002
Messages
4,908
Location
Somewhere in time.
#9
Did the default colors of the forum change? I didn't make any changes, and the forum colors have changed to a difficult-to-distinguish set of pastels. Starting today. My old eyes have to work harder to make out sections that have updates.
 

Stereodude

Not really a
Joined
Jan 22, 2002
Messages
10,252
Location
Michigan
#11
The colors are definitely different with the vB4 Default Style for the thread icons. Some of them are orange/red now. BTW, that's the only choice other than the Mobile style.
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
12,874
Location
USA
#13
Also the mini icon is wrong too. This is because of the upgrade and my mistake for not restoring the icons. I have all the files backed up and I'll restore them a bit later.
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
12,874
Location
USA
#15
I thought the upgrade happened weeks ago? This change happened only today for me (since Wednesday night your time).
Nope, late last night my timezone around 11:30PM EST. The files overwrote the images that I had changed for status icons. I have all of them backed up I just need to copy them over the originals and the problem will be solved.
 

Mercutio

Fatwah on Western Digital
Joined
Jan 17, 2002
Messages
20,329
Location
I am omnipresent
Website
s-laker.org
#16
I notice now that when I view an SF page with unread posts, mobile Firefox takes me to the anchor for the first post on the page rather than the first unread post, which I'm about 98% sure is what it used to do.
 

Handruin

Administrator
Joined
Jan 13, 2002
Messages
12,874
Location
USA
#18
I need to overhaul the mobile app. I'm seriously considering switching us over to XenForo and as one of the requirements I'm going to make sure there is good mobile browser support for a better user experience. I don't currently like using the mobile theme either as it's clunky and doesn't respond well. I don't have a solid timeline yet but part of it hinges on me getting my home lab configured so I have resources to experiment with before making the switch.

Things I'm planning are:
Updated forum software
Custom theme for SF
Improved mobile support
Revised forum logo to make more modern
Switch to MariaDB Galera Cluster (I need to test the hell out of this for a while before considering it)
Switch to nginx vs Apache or put nginx in front of apache for reverse proxy
Load balance (mostly for improved uptime with different region)
Improved secure backup process of files and database
More TBD
 

Tannin

Storage? I am Storage!
Joined
Jan 15, 2002
Messages
4,430
Location
Ballarat, Oz
Website
www.redhill.net.au
#20
Tea, read the thread before you reply, OK?
Anyway, you are using the desktop site.
(Posted with Firefox on Android, but also on the desktop site. One of the three nice things about Tea is that she, like me, hates mobile sites and never, ever uses them.)
 

timwhit

Hairy Aussie
Joined
Jan 23, 2002
Messages
5,278
Location
Chicago, IL
#21
I need to overhaul the mobile app. I'm seriously considering switching us over to XenForo and as one of the requirements I'm going to make sure there is good mobile browser support for a better user experience. I don't currently like using the mobile theme either as it's clunky and doesn't respond well. I don't have a solid timeline yet but part of it hinges on me getting my home lab configured so I have resources to experiment with before making the switch.

Things I'm planning are:
Updated forum software
Custom theme for SF
Improved mobile support
Revised forum logo to make more modern
Switch to MariaDB Galera Cluster (I need to test the hell out of this for a while before considering it)
Switch to nginx vs Apache or put nginx in front of apache for reverse proxy
Load balance (mostly for improved uptime with different region)
Improved secure backup process of files and database
More TBD
Hey Doug, have you had anytime to looking into this?
 
Top