VPN connects but no network

time

Storage? I am Storage!
Joined
Jan 18, 2002
Messages
4,801
Location
Brisbane, Oz
#1
I'm trying to connect to a corporate VPN endpoint, to allow remote access to intranet apps, etc. It's a M$ PPTP VPN.

I seem to have the problem at my home. A colleague tested my credentials at his home (with a Windows 10 laptop) and had no issues. I have tried two completely different Windows 7 desktops, without success. Also no joy with a Windows 10 laptop, but I seemed to get closer when I switched to a phone hot spot (and bypassed my router and ISP). Still didn't work properly though.

The VPN client connects OK, but Windows Network and Sharing Center shows an exclamation mark next to the client and a red cross next to "Internet". Status for the VPN is "No Network". Pinging doesn't get me anywhere. Network type is "Work" and Windows Firewall is disabled.

The router is a TP-Link Archer D2, which includes specific settings for VPN passthrough - they're enabled by default.

I can connect to other VPNs, but possibly not with the M$ client.

I've trawled the web for hours without finding a solution. Any ideas?
 
Joined
Feb 4, 2002
Messages
19,312
Location
Monterey, CA
#3
Howell might have it, other things to check would be any static routes on the workstation. If you can change the local IP/subnet on your router (and DHCP), I'd give that a go.
 

time

Storage? I am Storage!
Joined
Jan 18, 2002
Messages
4,801
Location
Brisbane, Oz
#4
Not a routing issue our conflict between local subnet in use and remote subnet?
Local subnet is 192.168.248.0, remote is 10.61.101.0.

Route Table:
Code:
===========================================================================
Interface List
[b][i] 25...........................Company VPN[/i][/b]
 11...44 37 e6 ae e8 6f ......Intel(R) 82579LM Gigabit Network Connection
  1...........................Software Loopback Interface 1
 13...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface
 16...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter #3
 26...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter #5
===========================================================================

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0    192.168.248.1  192.168.248.119   4235
[b][i]          0.0.0.0          0.0.0.0         On-link     10.61.101.151     11
    10.61.101.151  255.255.255.255         On-link     10.61.101.151    266[/i][/b]
        127.0.0.0        255.0.0.0         On-link         127.0.0.1   4531
        127.0.0.1  255.255.255.255         On-link         127.0.0.1   4531
  127.255.255.255  255.255.255.255         On-link         127.0.0.1   4531
    192.168.248.0    255.255.255.0         On-link   192.168.248.119   4491
  192.168.248.119  255.255.255.255         On-link   192.168.248.119   4491
  192.168.248.255  255.255.255.255         On-link   192.168.248.119   4491
[b][i]     xxx.xx.x.xxx  255.255.255.255    192.168.248.1  192.168.248.119   4236[/i][/b]
        224.0.0.0        240.0.0.0         On-link         127.0.0.1   4531
        224.0.0.0        240.0.0.0         On-link   192.168.248.119   4492
[b][i]        224.0.0.0        240.0.0.0         On-link     10.61.101.151     11[/i][/b]
  255.255.255.255  255.255.255.255         On-link         127.0.0.1   4531
  255.255.255.255  255.255.255.255         On-link   192.168.248.119   4491
[b][i]  255.255.255.255  255.255.255.255         On-link     10.61.101.151    266[/i][/b]
===========================================================================
Persistent Routes:
  None

IPv6 Route Table
===========================================================================
Active Routes:
 If Metric Network Destination      Gateway
 11   4106 ::/0                     fe80::xxxx:xxxx:xxxx:xxxx
  1    306 ::1/128                  On-link
 11     18 2001:44b8:2135:3e01::/64 On-link
 11    266 2001:44b8:2135:3e01:81f:914e:e627:19ae/128
                                    On-link
 11    266 2001:44b8:2135:3e01:f4ca:2513:b067:12d1/128
                                    On-link
 11    266 fe80::/64                On-link
 11    266 fe80::xxxx:xxxx:xxxx:xxxx/128
                                    On-link
  1    306 ff00::/8                 On-link
 11    266 ff00::/8                 On-link
===========================================================================
Persistent Routes:
  None
 

time

Storage? I am Storage!
Joined
Jan 18, 2002
Messages
4,801
Location
Brisbane, Oz
#6
We've done more testing, and the problem appears to be something to do with my user profile. Logged into a laptop through my home internet, I can use my colleague's credentials for the VPN just fine, but mine either achieve nothing or fail in various ways (now getting a check-your-network-configuration message). The IT Manager says there's only one group for remote access - I'm in it so therefore it works. :( In fact, the only time it worked was when creating a VPN from inside the firewall at the office; I could then ping a server's IP address, but not resolve the server name. My colleague had no problems with the same setup on the same PC in the same logged in session.

I have also tried the Watchguard Mobile Client with SSL. It just returns me to the password prompt every time I enter it. :(
 

time

Storage? I am Storage!
Joined
Jan 18, 2002
Messages
4,801
Location
Brisbane, Oz
#7
Epilogue: after I applied subtle pressure through management, the IT Manager actually checked and I was not in the access group after all. Apparently they didn't bother checking because everyone is in that group.

I have no words.
 
Top